import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\{.*?\\}";
final String string = "{\n"
+ " \"type\" : \"id\",\n"
+ " \"id\" : ${idOf('/tar/check/inof/high1')},\n"
+ " \"details\" : [\n"
+ " {\n"
+ " \"name\" : \"Sanio\",\n"
+ " \"sig\" : \"DA123QW\"\n"
+ " },\n"
+ " {\n"
+ " \"name\" : \"Tarer\",\n"
+ " \"sig\" : \"BAWE3QW\"\n"
+ " },\n"
+ " {\n"
+ " \"name\" : \"Kadek\",\n"
+ " \"sig\" : \"KSWE2J\"\n"
+ " },\n"
+ " ]\n"
+ " },";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}