re = /\$\{.*?\}/
str = '{
"type" : "id",
"id" : ${idOf(\'/tar/check/inof/high1\')},
"details" : [
{
"name" : "Sanio",
"sig" : "DA123QW"
},
{
"name" : "Tarer",
"sig" : "BAWE3QW"
},
{
"name" : "Kadek",
"sig" : "KSWE2J"
},
]
},'
# Print the match result
str.match(re) do |match|
puts match.to_s
end