// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$\{.*?\}").unwrap();
let string = "{
\"type\" : \"id\",
\"id\" : ${idOf('/tar/check/inof/high1')},
\"details\" : [
{
\"name\" : \"Sanio\",
\"sig\" : \"DA123QW\"
},
{
\"name\" : \"Tarer\",
\"sig\" : \"BAWE3QW\"
},
{
\"name\" : \"Kadek\",
\"sig\" : \"KSWE2J\"
},
]
},";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}