#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\*?(\d{1,8})\*?$"
Local $sString = "Valid results" & @CRLF & _
"" & @CRLF & _
"12345678" & @CRLF & _
"87654321" & @CRLF & _
"1112223*" & @CRLF & _
"12*" & @CRLF & _
"1345*" & @CRLF & _
"*123456*" & @CRLF & _
"*1234567" & @CRLF & _
"*1*" & @CRLF & _
"" & @CRLF & _
"Invalid results" & @CRLF & _
"1234567" & @CRLF & _
"A" & @CRLF & _
"12-" & @CRLF & _
"12@" & @CRLF & _
"**" & @CRLF & _
"**1234**" & @CRLF & _
"&T(" & @CRLF & _
"*" & @CRLF & _
"*1*2*" & @CRLF & _
"89789A8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")