const regex = new RegExp('^\\*?(\\d{1,8})\\*?$', '')
const str = `Valid results
12345678
87654321
1112223*
12*
1345*
*123456*
*1234567
*1*
Invalid results
1234567
A
12-
12@
**
**1234**
&T(
*
*1*2*
89789A8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}