// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\*?(\d{1,8})\*?$").unwrap();
let string = "Valid results
12345678
87654321
1112223*
12*
1345*
*123456*
*1234567
*1*
Invalid results
1234567
A
12-
12@
**
**1234**
&T(
*
*1*2*
89789A8";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}