# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\*?(\d{1,8})\*?$"
test_str = ("Valid results\n\n"
"12345678\n"
"87654321\n"
"1112223*\n"
"12*\n"
"1345*\n"
"*123456*\n"
"*1234567\n"
"*1*\n\n"
"Invalid results\n"
"1234567\n"
"A\n"
"12-\n"
"12@\n"
"**\n"
"**1234**\n"
"&T(\n"
"*\n"
"*1*2*\n"
"89789A8")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.