import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*?(\\d{1,8})\\*?$";
final String string = "Valid results\n\n"
+ "12345678\n"
+ "87654321\n"
+ "1112223*\n"
+ "12*\n"
+ "1345*\n"
+ "*123456*\n"
+ "*1234567\n"
+ "*1*\n\n"
+ "Invalid results\n"
+ "1234567\n"
+ "A\n"
+ "12-\n"
+ "12@\n"
+ "**\n"
+ "**1234**\n"
+ "&T(\n"
+ "*\n"
+ "*1*2*\n"
+ "89789A8";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}