const regex = /^.+(video\/|\/watch\?v=|embed\/|\/)([a-z0-9_?=-]+)$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+(video\\\/|\\\/watch\\?v=|embed\\\/|\\\/)([a-z0-9_?=-]+)$', 'img')
const str = `http://www.youtube.com/video/ZNvzVScj8ws
https://www.youtube.com/watch?v=ZNvzVScj8ws
http://www.youtube-nocookie.com/embed/ZNvzVScj8ws
https://youtu.be/ZNvzVScj8ws
https://www.youtube.com/embed/ZNvzVScj8ws`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}