// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^.+(video\/|\/watch\?v=|embed\/|\/)([a-z0-9_?=-]+)$").unwrap();
let string = "http://www.youtube.com/video/ZNvzVScj8ws
https://www.youtube.com/watch?v=ZNvzVScj8ws
http://www.youtube-nocookie.com/embed/ZNvzVScj8ws
https://youtu.be/ZNvzVScj8ws
https://www.youtube.com/embed/ZNvzVScj8ws";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}