import re
regex = re.compile(r"^.+(video\/|\/watch\?v=|embed\/|\/)([a-z0-9_?=-]+)$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("http://www.youtube.com/video/ZNvzVScj8ws\n"
"https://www.youtube.com/watch?v=ZNvzVScj8ws\n"
"http://www.youtube-nocookie.com/embed/ZNvzVScj8ws\n"
"https://youtu.be/ZNvzVScj8ws\n"
"https://www.youtube.com/embed/ZNvzVScj8ws")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")