use strict;
my $str = 'http://www.youtube.com/video/ZNvzVScj8ws
https://www.youtube.com/watch?v=ZNvzVScj8ws
http://www.youtube-nocookie.com/embed/ZNvzVScj8ws
https://youtu.be/ZNvzVScj8ws
https://www.youtube.com/embed/ZNvzVScj8ws';
my $regex = qr/^.+(video\/|\/watch\?v=|embed\/|\/)([a-z0-9_?=-]+)$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}