re = /^.+(video\/|\/watch\?v=|embed\/|\/)([a-z0-9_?=-]+)$/im
str = 'http://www.youtube.com/video/ZNvzVScj8ws
https://www.youtube.com/watch?v=ZNvzVScj8ws
http://www.youtube-nocookie.com/embed/ZNvzVScj8ws
https://youtu.be/ZNvzVScj8ws
https://www.youtube.com/embed/ZNvzVScj8ws'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end