package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b((m)|(M))age(s?)\b`)
var str = `cold damage
white mage
mages are the same as wizards and Wizards are the same as Mages
cold daMage
The Mage
`
var substitution = "${2:+w:W}izard$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}