const regex = /\b((m)|(M))age(s?)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((m)|(M))age(s?)\\b', 'g')
const str = `cold damage
white mage
mages are the same as wizards and Wizards are the same as Mages
cold daMage
The Mage
`;
const subst = `${2:+w:W}izard$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);