// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b((m)|(M))age(s?)\b").unwrap();
let string = "cold damage
white mage
mages are the same as wizards and Wizards are the same as Mages
cold daMage
The Mage
";
let substitution = "${2:+w:W}izard$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}