re = /\b((m)|(M))age(s?)\b/
str = 'cold damage
white mage
mages are the same as wizards and Wizards are the same as Mages
cold daMage
The Mage
'
subst = '${2:+w:W}izard$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result