#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\d. ,]+) - - \[(.*?)\] \"(GET|POST|PUT) (.*?)\s(\w{4}\/\d.\d)\" (\d{1,3})\s(\d{1,}) \"(.*?)\" \"(.*?)\" \"(.*?)(\d{20})\""
Local $sString = ""242.121.8.11, 10.130.0.49, 10.130.32.73 - - [14/Mar/2019:14:44:54 +0100] "POST /kasca/service/BpvrPersonProxy-v1_2 HTTP/1.1" 200 473 "12322" "Synapse-PT-HttpComponents-NIO" "CN=i-tst.test.com,OU=IT Team,O=Test,L=Lef,ST=Lolo,C=JK,serialNumber=00000014000000445000""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")