const regex = /([\d. ,]+) - - \[(.*?)\] \"(GET|POST|PUT) (.*?)\s(\w{4}\/\d.\d)\" (\d{1,3})\s(\d{1,}) \"(.*?)\" \"(.*?)\" \"(.*?)(\d{20})\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d. ,]+) - - \\[(.*?)\\] \\"(GET|POST|PUT) (.*?)\\s(\\w{4}\\\/\\d.\\d)\\" (\\d{1,3})\\s(\\d{1,}) \\"(.*?)\\" \\"(.*?)\\" \\"(.*?)(\\d{20})\\"', 'gm')
const str = `"242.121.8.11, 10.130.0.49, 10.130.32.73 - - [14/Mar/2019:14:44:54 +0100] "POST /kasca/service/BpvrPersonProxy-v1_2 HTTP/1.1" 200 473 "12322" "Synapse-PT-HttpComponents-NIO" "CN=i-tst.test.com,OU=IT Team,O=Test,L=Lef,ST=Lolo,C=JK,serialNumber=00000014000000445000"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}