using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d. ,]+) - - \[(.*?)\] \""(GET|POST|PUT) (.*?)\s(\w{4}\/\d.\d)\"" (\d{1,3})\s(\d{1,}) \""(.*?)\"" \""(.*?)\"" \""(.*?)(\d{20})\""";
string input = @"""242.121.8.11, 10.130.0.49, 10.130.32.73 - - [14/Mar/2019:14:44:54 +0100] ""POST /kasca/service/BpvrPersonProxy-v1_2 HTTP/1.1"" 200 473 ""12322"" ""Synapse-PT-HttpComponents-NIO"" ""CN=i-tst.test.com,OU=IT Team,O=Test,L=Lef,ST=Lolo,C=JK,serialNumber=00000014000000445000""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}