use strict;
my $str = '"242.121.8.11, 10.130.0.49, 10.130.32.73 - - [14/Mar/2019:14:44:54 +0100] "POST /kasca/service/BpvrPersonProxy-v1_2 HTTP/1.1" 200 473 "12322" "Synapse-PT-HttpComponents-NIO" "CN=i-tst.test.com,OU=IT Team,O=Test,L=Lef,ST=Lolo,C=JK,serialNumber=00000014000000445000"';
my $regex = qr/([\d. ,]+) - - \[(.*?)\] \"(GET|POST|PUT) (.*?)\s(\w{4}\/\d.\d)\" (\d{1,3})\s(\d{1,}) \"(.*?)\" \"(.*?)\" \"(.*?)(\d{20})\"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}