import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d. ,]+) - - \\[(.*?)\\] \\\"(GET|POST|PUT) (.*?)\\s(\\w{4}\\/\\d.\\d)\\\" (\\d{1,3})\\s(\\d{1,}) \\\"(.*?)\\\" \\\"(.*?)\\\" \\\"(.*?)(\\d{20})\\\"";
final String string = "\"242.121.8.11, 10.130.0.49, 10.130.32.73 - - [14/Mar/2019:14:44:54 +0100] \"POST /kasca/service/BpvrPersonProxy-v1_2 HTTP/1.1\" 200 473 \"12322\" \"Synapse-PT-HttpComponents-NIO\" \"CN=i-tst.test.com,OU=IT Team,O=Test,L=Lef,ST=Lolo,C=JK,serialNumber=00000014000000445000\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}