use strict;
my $str = '23123123
1
12
133';
my $regex = qr/\b\d{1,3}\b/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";