import re
regex = re.compile(r"\b\d{1,3}\b", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("23123123\n"
"1\n"
"12\n"
"133")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)