$re = '/\b\d{1,3}\b/im';
$str = '23123123
1
12
133';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;