#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([123]),((?!\1)[123]),((?!\1|\2)[123])"
Local $sString = "1,2,3; 3,2,1; 2,1,3; 2,1,3;" & @CRLF & _
"1,1,1; 1,2,2; 1,3,3; 3,3,1; 2,3,3;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")