import re
regex = re.compile(r"([123]),((?!\1)[123]),((?!\1|\2)[123])")
test_str = ("1,2,3; 3,2,1; 2,1,3; 2,1,3;\n"
"1,1,1; 1,2,2; 1,3,3; 3,3,1; 2,3,3;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")