$re = '/([123]),((?!\1)[123]),((?!\1|\2)[123])/';
$str = '1,2,3; 3,2,1; 2,1,3; 2,1,3;
1,1,1; 1,2,2; 1,3,3; 3,3,1; 2,3,3;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);