re = /([123]),((?!\1)[123]),((?!\1|\2)[123])/
str = '1,2,3; 3,2,1; 2,1,3; 2,1,3;
1,1,1; 1,2,2; 1,3,3; 3,3,1; 2,3,3;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end