package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`B(?<StartByte>[0-9])(?:.(?<StartBit>[0-7]))?(?:<<(?<LeftShift>[0-9]))?\|?`)
var str = `B0<<8|B0|B1.6<<8
B0.7<<8
(B0.7-B0.0)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}