use strict;
my $str = 'B0<<8|B0|B1.6<<8
B0.7<<8
(B0.7-B0.0)';
my $regex = qr/B(?<StartByte>[0-9])(?:.(?<StartBit>[0-7]))?(?:<<(?<LeftShift>[0-9]))?\|?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}