// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"B(?<StartByte>[0-9])(?:.(?<StartBit>[0-7]))?(?:<<(?<LeftShift>[0-9]))?\|?").unwrap();
let string = "B0<<8|B0|B1.6<<8
B0.7<<8
(B0.7-B0.0)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}