import Foundation
let pattern = #"B(?<StartByte>[0-9])(?:.(?<StartBit>[0-7]))?(?:<<(?<LeftShift>[0-9]))?\|?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
B0<<8|B0|B1.6<<8
B0.7<<8
(B0.7-B0.0)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)