#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^/]+/"
Local $sString = "customer-service/tweep/cs/gsergsergrs/2017-20190Course-Schedule.pdf"
Local $sSubst = "---/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)