const regex = new RegExp('[^/]+/', 'g')
const str = `customer-service/tweep/cs/gsergsergrs/2017-20190Course-Schedule.pdf`;
const subst = `---/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);