using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a.*href=""(([^.]+\.)+[^.]*)""";
string input = @"<a href=""2015-mail.com.html"">2015-mail.com</a>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}