re = /a.*href="(([^.]+\.)+[^.]*)"/
str = '<a href="2015-mail.com.html">2015-mail.com</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end