$re = '/a.*href="(([^.]+\.)+[^.]*)"/';
$str = '<a href="2015-mail.com.html">2015-mail.com</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);