using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(rgba?\((?:\d{1,3}[,\)]){3}(?:\d+\.\d+\))?)";
string input = @"linear-gradient(to bottom,rgba(255,0,0,0.4) 0,rgb(0,230,175) 100%);";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}