import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(rgba?\\((?:\\d{1,3}[,\\)]){3}(?:\\d+\\.\\d+\\))?)";
final String string = "linear-gradient(to bottom,rgba(255,0,0,0.4) 0,rgb(0,230,175) 100%);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}