use strict;
my $str = 'linear-gradient(to bottom,rgba(255,0,0,0.4) 0,rgb(0,230,175) 100%);';
my $regex = qr/(rgba?\((?:\d{1,3}[,\)]){3}(?:\d+\.\d+\))?)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}