// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(rgba?\((?:\d{1,3}[,\)]){3}(?:\d+\.\d+\))?)").unwrap();
let string = "linear-gradient(to bottom,rgba(255,0,0,0.4) 0,rgb(0,230,175) 100%);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}