package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(rgba?\((?:\d{1,3}[,\)]){3}(?:\d+\.\d+\))?)`)
var str = `linear-gradient(to bottom,rgba(255,0,0,0.4) 0,rgb(0,230,175) 100%);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}