using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href="".*?([\w-]+\.pdf)""";
string input = @"<a class=""btn btn-small pad-button"" href=""/Tests/English/english_2011_summer_A-Q_b.pdf"">eng1</a><br>
<a href=""english_2011_summer_A-Q_c.pdf"">eng2</a>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}