re = /href=".*?([\w-]+\.pdf)"/m
str = '<a class="btn btn-small pad-button" href="/Tests/English/english_2011_summer_A-Q_b.pdf">eng1</a><br>
<a href="english_2011_summer_A-Q_c.pdf">eng2</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end