import re
regex = re.compile(r"href=\".*?([\w-]+\.pdf)\"", flags=re.MULTILINE)
test_str = ("<a class=\"btn btn-small pad-button\" href=\"/Tests/English/english_2011_summer_A-Q_b.pdf\">eng1</a><br>\n"
"<a href=\"english_2011_summer_A-Q_c.pdf\">eng2</a>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")