import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\".*?([\\w-]+\\.pdf)\"";
final String string = "<a class=\"btn btn-small pad-button\" href=\"/Tests/English/english_2011_summer_A-Q_b.pdf\">eng1</a><br>\n"
+ "<a href=\"english_2011_summer_A-Q_c.pdf\">eng2</a>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}