const regex = /.*\bsigned.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\bsigned.*', 'gm')
const str = `The document was signed on July 12
The document was signed by Charlie
This document was assigned to John
The document was preassigned to Amanda`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}