$re = '/.*\bsigned.*/m';
$str = 'The document was signed on July 12
The document was signed by Charlie
This document was assigned to John
The document was preassigned to Amanda';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);