using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<span id=\""MyId\"">|\G),?([^<>,]+)";
string input = @"<html>
...
<span id=""MyId"">string 1,string 2,string 3,strin4,string5,string6</span>
...
</html>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}